Calibrate Compass Without Starlink?

Discussion in 'X-Star / X-Star Premium' started by LabRat1957, Dec 16, 2018.

  1. Is it possible? I've never even thought about trying it until yesterday. I went to fly and each time I tried to calibrate the compass, the app would disconnect. I've never had this happen before. The disconnect occurred each time during the nose down part of the calibration. It did it several times. Weird! It was just the app though. The controller displayed normal data except for the "app disconnected" message at the bottom. After restarting everything, I was able to fly without any issue. I flew two flights and the XSP landed (RTH) itself within a foot of its takeoff point for both. I know the XSP can be flown without a tablet or phone. That's at least one reason for having the small screen on the controller so... the compass must be able to be calibrated as well right? I've just never attempted or thought about it before. If I encounter this issue again I may have to contact Autel about service but, I thought someone here might know something about this.
     
  2. Are you asking if you can calibrate the compass with the controller alone? As you found, yes.
     
  3. Yes. That is what I was asking. I thought it could be done. I've never done or had to do it. I'll have to try it that way a couple times to get used to not hearing the "compass calibration completed successfully" from the app. Thanks for the reply!
     
  4. Well, this XSP must have developed some sort of issue. The StarLink app disconnected again today as I attempted compass calibration. Again it was nose down. I reset everything without starting StarLink and successfully calibrated the compass without it. I then connected to StarLink again and all was fine. I flew two flights, used the RTH to bring it back to land within a foot of the takeoff point each time. I have no idea what is causing the app to disconnect, and may have to contact Autel. The XSP flys perfectly in every other respect.
     
  5. Try uninstalling and reinstalling the starlink app.
     
  6. Will do ASAP!
     
  7. OK. I uninstalled then reinstalled StarLink. Now I'm getting and app disconnected message even as the XSP sits on my table and I'm just a few feet away. It did not recover video even after I closed and reopened the app. The connection between the XSP and the controller appeared good since the small display on the controller was showing vitals. I could move the camera, and start the motors. Correct me if I'm wrong but an app disconnect has little to do with the drone itself? This is a controller to viewing device connection problem? Maybe I have a cord problem.
     
  8. Tried again after work today. All was good with the connection this time. I'll take a test flight tomorrow. I think the connection cord is the weak link.
     

Share This Page