Camera Disconnected, RC Disconnect

Discussion in 'X-Star / X-Star Premium' started by Philip Andrews, Nov 28, 2017.

  1. I ran the beta versions of the latest f/w without issue. Just downloaded and installed release version, updated IOS Starlink app. Running on iPad Pro or iPhone 7+ with latest iOS version.
    Drone and rc connect, I have video link and lcd shows everything working. Starlink is not recognizing the camera, the sd card, or the rc. There is an error message saying rc disconnected. I have tried all the usual solutions without success. Has anyone else had this issue or have a solution? Autel customer service contacted and they are stumped, ended up saying to send it back in.

    I sent my drone in they claimed that it was a bad gimbal board. They claimed to have “replaced” it. I received it today and low and behold the issue was still there. I called back in and talked to CS rep Darik who seemed to think that the only thing that it could be was the SD card.

    After repeatedly telling him it wasn’t he said he couldn’t do anything else till I tried a different SD card. I got one put it and and still the issue. Waiting on a call back now.
     

  2. Having the same issue tonight. Identical in how you describe it. Aircraft flies fine, camera responds to remote controls, Starlink is (mostly) functional, but it seems there is a data disconnect between. Any app-requested commands are unresponsive (compass calibration doesn't work, any attempts at settings changes doesn't stay changed, camera settings are non-functional) even battery data, serial number of the aircraft, etc are “N/A”. I even went so far as to re-bind the aircraft/remote. I have not upgraded my firmware to v 2.x on the aircraft/remote, running 2.05 (latest) Starlink app. Did you ever figure out what was going on?
     
  3. It’s the iOS 11 I think. My iPad is on iOS 10 and it works fine.
     
  4. Thanks for the heads up. I was about to pull my hair out. Jumped on the App Store and it appears we’re not the only ones having the problem. Hope Autel or Apple fixes this soon. Call me overcautious, I just don’t feel comfortable flying without full control. Maybe I can find a used iPhone stil running iOS 10 or older.
     
  5. Android works great for me (Just sayin (LoL))
     
  6. During the flurry of recent IOS releases, a few bugs got by Apple that impacted the Starlink app. I verified on a number of Apple products from iPhones and iPads. All worked fine until I tried an iPad Air with 11.2. The camera controls became completely inoperative. All other features of the app seemed to be working properly.

    Autel is very aware of this issue and sent me the following last week.

    "We are working along with Apple, as well as other developers from other companies working with Apple in regards to similar issues with the latest releases of iOS. It's top priority for our team, but we do not have a time or date as to when a fix will be applied. If you are running an older iOS, then it seems to be not interfering with those."

    Time will tell if patience is, in fact, a virtue.....
     

  7. Well it’s good to know they are aware of it and not trying to pass the perverbial buck. Knowing Autel’s customer service I imagine they’ll have a fix soon. For me anyway, this time of the year I’m not flying much so it couldn’t come at a better time. Now if this is still going on come Spring...
     
  8. I have no doubt Autel will do their part when the time comes. The big unknown is when Apple will do their part.
     
  9. Help!! can anyone help me with this problem? I have a very big problem getting my Tab A connect to the controller. I have a video on you-tube if anyone would like to look and tell me what they think. Sometimes it will connect and some not.

    .
     
  10. First of all due to my own connection problems I only got to see about a minute of your video but the first thing I would try is to move to a more open spot and try again. You are surrounded by way to much metal.
     
  11. The blinking yellow lights indicate it's not connected to the RC (I believe). Unplug the Tablet and see what happens. Regardless, try to start then manually take off to a height about 3 ft. Then land. What happens? I upgraded the firmware several weeks ago. Similar things started to happen about 2 weeks ago. Re-paired yesterday - it's worse, along with other issues (no go home feature - it just lands wherever it is when I press the Go Home button.

    Reported the issues to Autel CS this morning after extensive testing yesterday - Multiple XSP's, RC's, Cables, FPV devices (IOS and Android). I have an acre or property and have never had a problem with environmental interference before, Even went to a huge grassy park with no one in sight. Same issues.
     
  12. I did notice your RC antennae are directed at an outward angle. All the videos and documentation I have seen indicated to set them parallel to one another and pointed in the direction of the XSP. I could be wrong - others to comment?
     
  13. My first guess I would say your usb cable (try another). Second guess if it's not the cable I'd say usb port (probably on the RC).
    Actually I just re-read your post. The problem is the newest version of iOS. They are working on a fix.
     
  14. #14 kroorda, Jan 8, 2018
    Last edited: Jan 8, 2018
    People using iOS 11xxx. The problem is with iOS 11, and not with Starlink or the aircraft.

    When a company prepares and writes a new OS, (whether it be Microsoft, Linux, or Apple), that company provides a set of parameters that users of the OS must adhere to. Unfortunately, if the OS producer has flaws in it's OS, then there is nothing that 'users' can do. Autel is far from being the only company that is affected by the 'Apple Error'. Unfortunately, a lot of stones have been thrown at Autel for this problem that they have no control over. If they (Autel) write a 'fix' to address the iOS error, then, when Apple fixes the error, then the fix will no longer work.

    To make matters worse, it appears as though you (Apple users who updated to V11) can not 'roll back' (to an earlier (bug-free) version) without consequences. (Loss of all data).

    Apple has never been good at 'playing well with others'. However, they are now being forced to play well. My suggestion is to put the pressure on Apple and remember that there are Android devices that will perform very well; often at a lower price.
     
  15. I also am using the Galaxy tab A and mine is android ( I am having no problems connecting) I would try it with out any device connected and see if just the RC will connect. I would also try a different USB cable, kind of hard to tell but in a couple of shots it almost looks like the cable isn't even connected to the back of the controller
     
  16. #16 kroorda, Jan 8, 2018
    Last edited: Jan 9, 2018
    xyz
     
  17. You actually can roll back but you will lose everything on your tablet/phone. If it's a tablet/phone dedicated to the XSP then I'd see no problem in rolling back because you would have a very clean system to start over from. Just re-download your apps needed.
     
    kroorda likes this.
  18. Turfagon, you are correct. Thanks for your clarification. :)
     
  19. Yeah, it's like downgrading your operating system from Windows 7 to Windows xp. Software downgrade like an OS is no problem. Firmware downgrades/rollbacks on the other hand can't be done.
     
  20. Posts #13, #14, and #16 keep referring to iOS. He's using an Android device, (Tab A) not iOS so it's not that. My own experience with disconnects seems to be the cable although I haven't proved that 100% to my own satisfaction. So far I have not had an issue since I've gone to a shorter and higher quality cable. I have had a disconnect when the XSP was out a great distance, although the connection recovered when the XSP came back closer to the RC. He may want to try one or more different cables. I'm using Anker. I've found one that is just 12-inches that works quite well and does not leave any excess cable dangling to get hooked on something. The USB connection port on the RC is also of poor design and could lead to damage of the connection if great care is not taken when sitting the RC down. Anything loose there will cause a connection problem.

    I agree with another poster above that he is surrounded by too much metal. There has to be interference from the other residences around also. Try to find a site away from all that to test your connection.
     
    Kun Bow likes this.

Share This Page