Can't stay connected to app or controller

Discussion in 'X-Star / X-Star Premium' started by Robert Goldberg, Jul 30, 2016.

  1. Hi folks. I am having real problems with connectivity. I love the drone and when everything is connected, it's absolutely awesome. However, I seem to lose connections when I am not very far away with the drone from the controller. Let me give you some details.

    1. I have the latest firmware on everything.
    2. I have tried using my iPad 4 and my Alcatel One Touch Idol 3
    3. I am using third party cables right now that have a right angle connector on the USB side that connects to the controller. I have one with a micro USB on the other side for my Alcatel phone and one that has a lightning connector on the other side for my iPad 4.

    The problem is that it seems that within 4-5 minutes of connecting to the app, I always lose the connection. Then often it seems that right after that I lose connection to the controller.

    On the humorous side of all this, I lost all connections to the drone this morning. It started to come home but it was too low and flew right into the top of a huge tree that was not more than 50 feet from me. I had to go home and retrieve my 25' ladder and an extension pole to have any chance of getting up into that tree. The humorous part is that by the time I got back from my house with my ladder and stuff, there must have been 10 people standing around the tree talking about how to get the drone down. I had like 5 people helping me, holding the ladder, waiting on the ground to catch the drone, etc. I met lots of really nice people. It was a real conversation piece, although not in the way I wanted the drone to do that :).

    Ok, back to the real issues. I am very frustrated with these connection problems. It seems like everyone is having a great time flying the drone and I am too when I can stay connected.

    I really need some help knowing what might be going on here. Could it be the cables? Should I not expect my devices to work properly? Do I need some other device to get satisfactory connections? Do I have to start discussing this with Autel directly?

    Thanks folks. Looking forward to using this forum a lot.

    Rob
     
  2. Robert,
    Sorry to hear about your issues, I am sure it is frustrating. Do you have anyone who may have one of the approved devices in the Autel list. Neither of the devices you mention are on the list, tho there are devices not on the list that are working. Try to find someone with an iPad Mini or an Android device that is listed. I have used a Note 5 , LG VK815, Galaxy Tab A, Galaxy Tab S2 and all stay connected. Good luck.
     
  3. Just purchased a used nvidia shield K1. Seems like they work pretty good from what I've been reading. I hope I'm right.
     

  4. Does it happen every time you are out with it. Have you tried using the supplied USB cable. IF not, I would give that a go as well to see if if makes any difference. IF you have already, then I would wait to see how it fares with the K1 tablet... Just make sure to update it with the most current patches...
     
  5. I get my K1 tomorrow so I will be able to take the xstar out and see how it does with the K1. I will try it using the cable that came with the drone as well with my iPad.
     
  6. Hi Robert.

    Have you had an opportunity to check it out with the K1?
     
  7. No I have not. I am hoping to try it later today but it might not be until some time tomorrow. Just too busy.
     
  8. Hi folks. Due to the fact that I own and operate an entertainment company in addition to my full time job as a computer systems engineer, I have not had time yet to take my drone out with the K1 tablet and test.

    However, I know a bunch of you have the K1 so I am going to ask a question here: I have a Cricket Wireless plan with unlimited data. I am actually using an ATT LG V10 as my phone. I am trying to USB tether the K1 to the phone so it can get internet using the phone's connection. I am using the Easy Tether app to try to accomplish this. I was able to get a connection and a couple of apps worked but many said I didn't have an internet connection. Now I know if you bluetooth tether that will happen a lot since many apps just look for cellular or wifi but not bluetooth. However this is not a bluetooth connection. Have any of you successfully tethered your K1 to your phone to use it's internet connection and if so, how did you do it? I can't use regular wifi hotspot or tethering since the carrier disables it on unlimited data phones.

    Rob
     
  9. Hi, as you hold the power button on the controller in the top left does it say CE or FCC?
     
  10. I will have to check when I get home from work tonight. What is the difference? Can explain what that means? Thanks.
     
  11. Depending on your location the controller sets accordingly and unlucky for myself I'm in the UK and it is set to CE which halves the power output. If your on fcc your on full power.

    Hope this helps
     
  12. Well That Totally Blows. No place in settings to override that? Seems like their advertising ought to list that little TidBit of information pretty prominently! Is that to protect you from electromagnetic radiation or to make you comply with their flight restrictions over there?
     
  13. It's to comply with the rules over here but like you say should be able to overide but not possible.

    What also gets me is that we use Pal for video and once you switch to pal for an example 1080p the maximum rate allowed is 50fps
     
  14. So the X-Star Starlink App is recognizing by GPS that it is flying on the other side of the pond and is automatically forcing a downgrade of signal strength thereby limiting it's own range capabilities and forcing you to record in a format that is accepted in your country or is Autel setting those default parameters into the unit prior to shipping to shipping it to you to comply with the law in order to gain permission to sell or even just set it up to comply & conform for your "convenience".

    I'm sure there exists the ability to hack the capabilities of the X-Star to restore the features of the unit you desire. Probably just a matter of using a USB cable directly to the X-Star and the Transmitter and changing the parameters directly on the board and not in the app as Starlink should have nothing to do with signal strength. You don't even need Starlink to fly it so I would think it is preconfigured prior to shipment in order for Autel to gain permission to sell it in UK but I doubt they made it something that cannot be overridden by a determined user. Perhaps there are dip switches on one of the internal boards?

    Your compliance with the law in UK is up to you & not Autel so I find it hard to believe they would be motivated to prevent you from customizing your craft or transmitter according to your needs. Have you pressed Autel support for instructions on restoring the capabilities of the craft?
     
  15. I have FCC showing on my controller when I boot it up.
     
  16. Try rebinding the controller to your X-Star.
     
  17. Screenshot_2016-08-16-07-28-53.png

    This was the response I got regarding my situatuon with CE & FCC
     
    4 people like this.
  18. Well you can certainly understand they have to comply with local authority on the CE thing. Shame they implemented it based on GPS in a manner that cannot be overridden. I'm sure a workaround will eventually be found by someone in the UK savvy enough to get in there and determine the actual implementation & explore methods of customizing the settings.

    I guess you could always return the unit based on them not disclosing this rather important bit of information prior to selling you the unit. I do eel your pain & wish you well in what you choose to do.
     
  19. Thanks and I'm sure there will be a work around at some point. I do know this has been passed on to the Dev team so hopefully they will work on it in a future fw update.
     
  20. OK, well I seem to have worked through the initial connectivity problems, at least the ones that occur while still on the ground. I am now having the app connect successfully every time. Problem seems have been firstly the cable (weird but different cable helped) and then the order that the steps are followed. I now start with the app not even open. I start the controller, then the drone, once they connect the app automatically opens and connects right away. Doesn't seem to matter whether the USB tether is in Charge, MTP, or PTP mode.

    So today I am finally ready to fly the drone again and I have a new problem. No matter where I go all I get is Magnetic Interference. Even in spots I've flown before. I spoke with Benjamin at Autel and he suggested that maybe my cell phone was causing the issue. I guess the drone/controller use 5.8Ghz and most modern phones have 5Ghz support. So I tried a couple of spots without anything in any of my pockets and still could not get cleared for takeoff. I am assuming the 5.8Ghz being used is the same frequency band that almost every current router supports in every house, etc. That's correct isn't it? If so I wonder why they picked that frequency since it seems to me at least that everywhere there would be devices putting out that frequency.

    At any rate, I don't live on a farm or even near one. I am not near the ocean. I don't want to fly the drone over a croweded park. So I don't know where to go to fly the damn thing. Spots I've used in the past aren't working anymore.

    Anybody have any ideas? I'm not hopeful that you do but I know there are people in this forum with vastly more experience with all this than me. I am a techie but a newbie at this hobby.

    Thanks,
    Rob
     

Share This Page