Connecting a new iPad

Discussion in 'EVO' started by Rick Hartman, Nov 16, 2021.

  1. Hi,

    I just got a new iPad mini 6 to use with my Autel Evo I. The controller won't recognize it. I have tried changing cables and that had no impact. The iPad is running iPad OS 15.1. My iPhone Xs running iOS 15.0.1 works just fine. I am at a loss of what to do next especially since we have been cast adrift by Autel. Any ideas or help would be greatly appreciated.

    Rick H
  2. Hello Rick, I'm having a similar issue with my iPad pro, I'm hoping that someone will answer your request. If you were able resolve your issue, please post it so I can maybe solve my problem. Thanks, The information on my system:
    Model: V2
    Drone Firmware Version: Model-C_FW_V2.7.25
    APP Version: V1.1.8.3
    Firm Ware Version:
    Flight Control v0.0.4.85
    Camera V0.3.0.0
    Remote Control V4.0.0.11
    Image Transmission V2.0.0.50
    Remote Control Image Transmission V2.0.1.50
    Gimbal: v0.1.55.0
    Battery V0.0.16.0
    Vision Module V0.3.0.0
    Sonar V4.0.0.3
    ESC1 V1.0.3.6
    ESC2 V1.0.3.6
    ESC3 v1.0.3.6
    ESC4 V1.0.3.6

    Gimbal Serial Number
    Aircraft Serial Number
    Remote Control Serial Number

    Pro V2 | MDCA

    Aircraft S/N:
    Remote Controller S/N:
    Gimbal S/N:
  3. I contacted Autel but didn’t tell them I was flying an OG Evo. They told me that mini 6 worked just fine. Then I told them what I was flying and the very quiet response was, “Oh yes, there’s a known problem with that. And since they don’t support it anymore that was the end of the conversation. I Ende up buying a very cheap Android tablet to fly my Evo with.

Share This Page