EVO video transmission inoperative

Discussion in 'EVO / EVO 2' started by DaveRossiter, Jun 20, 2020.

  1. Hi guys. I receive no video from my 2-months old EVO. It began intermittently, only on occasional startup, and now I have no video transmission at all. I have tried re-starting components in various order but this doesn't work either. Control datalink still works and she flies fine but, receiving zero video.
     
  2. Are you using the controller to view the video or are you attaching a phone/tablet?
     
  3. I have tried both and neither video display functions. Any help appreciated. Thanks
     
  4. This did happen to mine a few times however after a few restarts of both the battery, controller and phone it worked. Sometimes I have to turn the drone on, then the controller and then phone and then plug it in it seemed to work. Not sure why the order of what is turned on matters. This only happened for a few select times but its worth a shot. Moving forward, I always turn on phone last and then do I plug the phone into the controller. If that doesn't work, I would reach out to Autel
     
  5.  
  6. Thanks, Nick. Yes, I have tried all these options to no avail. Sending her back to Autel tomorrow.
     
  7. Try rebooting your phone or iPad whichever you’re using, sometimes this is the problem.

    Good luck
     

Share This Page