I have problems with my x-star premium

Discussion in 'General' started by Jesse Gardner, Dec 25, 2017.

  1. Hey guys i am having some problems with my x star premium and i can't figure it out i am hoping someone knows what to do. When i turn it on in the overall status menu the sd card says it is n/a even though i can plug it into my computer, the command stick mode says rc disconnected and the radio strength signal is at 0% the compass is also abnormal and the drone is in atti mode. When i try to calibrate the compass or the remote controller i push on the calibrate button and then it doesn't do anything and won't let me calibrate it. Also i tried resetting the camera to see if that worked but it said the camera was disconnected even though i can see the live camera on the screen. If you have any idea what the problem might be or how to fix it please let me know. Thank you, Jesse
     
  2. Make sure that the camera is securely snapped in on the gimble mount. If that doesn't work, then give Autel a call. They are very responsive and helpful.
     
  3. Check the legs of your drone I believe there is a antenna wire going down one leg and a compass wire going down another leg, check for physical damage or broken disconnected wires. If not I agree with kroorda to give Autel a call.
     
  4. Okay sounds good thank you guys
     
  5. What OS are you running on your device?

    I encountered different (but similar) issues a few weeks ago. One day everything was working find and the next it wasn't. Long story short, turned out to be the USB cable went bad. I hadn't been disconnecting the cable from the controller before setting it down after use. The cable extends straight down from the RC and bends abruptly. On a "gut check" I replaced it with another cable I had in a drawer.

    Problem solved.

    Good Luck - Let us know what you find out.
     
  6. Busdriver,
    Good find. I ordered and use an USB cable that 'bends' at a 90 degree angle so it does not bend abruptly out of the controller. (advice from other forum members).
     
  7. Yep, thanks. Forgot to mention that part. I found one of those as well. The RC doesn't tip over when I set it down anymore (that should have been my first clue months ago that something wasn't right.)
     

Share This Page