Issue with Starlink App

Discussion in 'X-Star / X-Star Premium' started by Robert Goldberg, Nov 20, 2016.

  1. Hi folks. So this past week I was in Hawaii and I took my XSP with me. I flew about 4 batteries worth of time on the Big Island. What I experienced a number of times was complete loss of contact with the app. Not with the controller, with the app. I thought it was just a loss of video but as I would fly the quad closer and closer to me it would not recover. Not even closing and restarting the app helped. I literally had to shut down and reboot my Samsung Galaxy Tab S2 tablet to get the app to connect again. And this wasn't a one time event. It happened about 4 times during my flights. It was never a problem getting the bird to come home but it was very disappointing to have to reboot the tablet to recover. I don't know what else to say. Anyone else experiencing anything like this?

    On the good side, the RTH function was flawless, landing the bird multiple times inches from where it had taken off. Thank heavens for that.
     
  2. I have never had that issue. Which version of the app are you running? There is a new version, even though autelrobotics site still says 1.03.07. If you haven't yet, download it and see if that fixes your problem.

    Android V2.0.1.18 is the latest.
     
  3. I am already running the latest beta version.
     
  4. 1.03.07. is the firmware version which is different than the StarLink version.
     
  5. I had this issue with my ASUS ME181c, worked fine for a while then started disconnecting the APP. Support didn't know why I was having the issue so I bought an Nvidia K1.

    Supported Samsung devices as per Autel list;

    Samsung Galaxy S6 Android 5.0.2
    Samsung Galaxy Note 4 Android 4.4.4
    Samsung Galaxy Tab A Android 5.0.2
    Samsung Galaxy Note 5 Android 5.1.1
    Samsung Galaxy Tab S Android 5.0.2
     
  6. Delete and reinstall the latest version app. Worked for me. Good luck!


    Sent from my iPhone using Tapatalk
     
  7. I've been having problems with it too. The app keeps crashing on the nexus10 I'm using.
    i don't want to have to get a 2014 tablet at 2017 prices. I'm lobbying for a Microsoft app...
     
    2 people like this.
  8. I'm a random guy on the internet, so you know what follows is gospel. . . :)

    I suspect that issues with the stability of StarLink on Android devices is more a function of what else is installed and running on the tablet and not the stability of the app itself.

    Really, everyone running the same version of StarLink is using the same compiled bit of code. Problems would be much more widespread if the code were super buggy.

    Streaming of video and telemetry to the device takes a lot of real-time processing power. Anything running on the device that is not supporting flying the aircraft is taking away precious processor cycles and eating up the meager amount of RAM that all running processes have to share. When RAM runs low that's when things become unstable.

    My suggestion for those having StarLink issues is to go into your device and remove all the apps that you don't need and disable everything that you don't need running. In my case, I bought a Galaxy Tab A 7" to use exclusively for flying ($99 at BestBuy, they're giving the things away) I then removed all the crap that I could and disabled everything else. The Tab A works perfectly (so far. . .)

    Cheers,

    Dan K.
     
    3 people like this.
  9. Update: I relented and ordered an Nvidea Shield. It's still the best option.
     

Share This Page