Missing Connection XSP to RC

Discussion in 'X-Star / X-Star Premium' started by CarlS, Nov 25, 2018.

  1. Hi all.

    I had my XSP out flying yesterday with no problems.
    When I took it out again today. I was not able to get a video link, but I was able to fly it.
    When I got it home, I tried addressing the video link issue by toggling the Flight Mode Switch, per page 53 in the manual.

    Now, the message on the RC says "Connect your aircraft", and the Starlink app on my phone says "Aircraft Disconnected", and I can't get it to connect.
    The rear lights are doing a slow yellow flash.
    I tried pressing the remote control binding button an the left side of the aircraft, but that didn't help.

    The firmware file I have is X3P_FW_900M_V2.0.12.bin, and that was installed on June 5 of this year.

    I'm probably missing something basic here, but if anyone has any ideas, I'd appreciate hearing them.

    Thanks,
    --Carl
     
  2. Hi Carl, The flashing yellow lights on the drone indicate that there was no link to your controller. Were you getting any 'interference' notification on the controller? Did you have a good battery charge on the controller? Were the controller antennas up and parallel with each other? If yes to all those questions, then try to rebind the aircraft to the controller.
     
  3. Hi Cori,thanks for your response.

    I didn't see any interference notification on the controller.
    The batteries are fully charged on the controller and the XSP.
    The antennas are up and parallel with each other.

    I followed the steps outlined in the Autel tutorial on YouTube for pairing the XSP to the controller.
    When I finished, the message on the RC had changed from "Connect your aircraft" to "Video Link Disconnected".
    The Starlink app on my phone still says "Aircraft Disconnected", and the camera display is black..

    I'm using the USB cable supplied by Autel. I tested the cable by using it to connect my phone to my computer, and I can see the files on the phone, so I'm assuming the cable is ok.

    The phone I'm using for a display is an Android Galaxy S6.

    --Carl
     
  4. Try connecting your controller to your xsp without your phone or any other device (this by passes starlink all together). You can also try uninstalling and re installing starlink. If you have a second battery try that also.
     
  5. Thanks for your response copshopmech.

    I tried connecting just the controller to the XSP with no display device.
    The message on the RC still says "Video Link Disconnected". The rear lights were doing a slow green flash, and I was able to fly it.
    I tried my second battery, and that made no difference with the Video Link issue.

    I haven't tried uninstalling and re-installing Starlink yet, as I want to settle the Video Link issue first.
    Could the Video Link message be caused by not having a display device connected?

    --Carl
     
  6. Short answer, NO I fly mine frequently without a device connected. You have to keep a good LOS but I do it do sharpen my drone flying skills. The device distracts me I also remove the gimble/camera, also not needed to simply fly and I don't get no messages. If I were to take a guess on what you have said here it sounds like your problem maybe in the controller more specifically where the USB cable connects. It seem like the controller is sensing something connected (where it actually aint) but with no video link hence the message. There could be something broken or shorted at that connection point, again just a guess but might not be a bad idea and contact Autel.
     
  7. It really is surprising how much information travels through the camera connection. Autel recommends cleaning them from time to time. A contact cleaner or rubbing alcohol will clean of any oxidation that might have formed over time limiting a proper connection.
     
  8. Thanks for your inputs copshopmech and GForman.

    I didn't have any contact cleaner handy, but I did try detaching, then re-attaching the camera assembly, and that appears to have fixed the problem.
    The aircraft is now connected to the remote control, and the video is now working.

    Again, thanks!

    --Carl
     

Share This Page