New Firmware update available (NOT)

Discussion in 'X-Star / X-Star Premium' started by Jim Selleck, Sep 10, 2016.

  1. #1 Jim Selleck, Sep 10, 2016
    Last edited by a moderator: Sep 10, 2016
    I can't fly my X-Star Premium today. Starlink won't let me. Although I installed v1.2.8 last week and have flown 3 times since without a problem, as of this morning Starlink suddenly comes up with the cheery message: "New firmware version available!" When you click on the little green Info icon, it tells you all about the joys of version 1.1.3 (which I just upgraded FROM). If you try to ignore that screen and hit Start, the Module Check gives a big red "Abnormal" and a big orange "New firmware available".

    Actually, you MIGHT be able to ignore that and fly anyway, but clearly something is WRONG with the system so I am not going to risk it. I tried the usual stuff, like trying to reinstall v1.2.8 (it unpacks, then immediately tells me everything IS up to date) and uninstalling and redownloading Starlink. Also tried using a different Android pad to run Starlink. Same everywhere.

    Is anyone else having this strange problem??

    NOTE: Also just tried restarting everything using a different battery. Same issue.
     
  2. Hold the bus! Just received a callback from Autel Robotics support. He listened carefully and asked all the right questions, then told me this is actually a KNOWN issue that is on the list for correction in the next firmware update (the real one).

    MOST IMPORTANT (to me): He said this does NOT reflect any malfunction of other systems and it IS safe to fly.

    Of course, now its raining. Oh well...
     
    3 people like this.
  3. I keep seeing that message too, but I have always been able to click the Start button and go on.

    Go away rain and let this man fly.
     
    3 people like this.
  4. A lot of people have mentioned this problem in various "forums", including this one. another forum, and all three Autel X-Star Facebook groups. It is not a problem for iOS users, but the Android Starlink thinks that 1.1.3 is the latest and is checking for equality, not "greater than".

    Although I have no idea why there are three Facebook X-Star groups, it does seem to be the most active channel for information. One has ~200 members, another has ~650, and the largest has ~2500. Some people post in all three.
     
  5. Quick update from an iOS user: I have had this issue too. I need to fly again to see if it is still a thing, but I just ignored it after some initial fear. I have a standard X star btw if that makes a difference.
     
  6. I just had my Starlink app updated....Android issues seem to be gone. Voice startled me when first started.
    This has been available since 10/26/16 per Joel at AR on line support.
     
  7. That is the beta version that was available a couple of weeks ago. Guess it is out of beta now.

    It says

    But I don't see how to remove the distance limit in waypoints. I looked everywhere in the general settings.
     

Share This Page