No Sonar Firmware in Drone?

Discussion in 'X-Star / X-Star Premium' started by robval1987, Jan 16, 2017.

  1. Autel is quick to respond to your calls, but I've noticed that there seems to be a diconnect from the individuals that answer the phones and the individuals (techs) that actual know what's going on. I recently purchased 2 new batteries and was told that I needed to download the firmware from the Autel website and install it for the new batteries to become matched to the aircraft. I was also told to run the firmware on the original battery that came with the X star premium. So upon completion of updating all three batteries my problems began. First think I saw was on battery #2 I received a warning on my monitor (unknown battery) while flying, I immediately landed the drone, powered everything down and turned everything back on. I didn't see that warning again for a couple of flights, but upon seeing I contacted Autel and they advised that I run the firmware on that battery again. Then the other day I was out flying and the drone had about 33% battery life left, and I knew it would be going into RTH soon so I let the aircraft go into a hover apprx. 650 feet away from me at approx 35 feet high. At 25% the drone did as it was suppose to and went into RTH mode. The aircraft went to 99 feet as preset and I thought it was on its way home, but it remained at 99 feet and wouldn't move (I mean nothing) I had zero control of the drone, it just sat there at 99 feet in a hover, then less then a minute later I got a critical low battery warning, I expected the drone to go into landing immediately phase, but yet again nothing. I tried everything that I could think of to get the drone to come down, the only thing that I noticed that worked was pressing the pause button the drone began a decent, so I let go of the pause button, but the drone began to climb and went back to 99 feet. So I again pressed and held the pause button and the drone began to come down (with 1 minute of flight time remaining I continued to hold the pause button as the drone was coming down and I didn't want it to return to 99 feet run out of battery life and fall to the ground. Pause was bringing it down, so I continued to hold it as it got about 5-6 feel from the ground my son (which had been out flying with me) reached out and grabbed the landing gear, I released the pause button and the motors reved back up as if it were attempting to climb, he pressed the power button on the battery and powered down the drone. I called Autel and explained to them what had just happened and the requested screen shots of all my batteries and the requested the bin files from the drone. They also request screen shoots of my firmware. I sent in all the info they requested and I waited for a response, 2 days later I called in to Autel to see if the had any info for me. They asked when I had last updated the firmware, and I told them 2 days ago. They said they could not see anything wrong with the drone or the batteries (but I did) after Autel requested all that info I powered up my son's drone (x star premium) and verified the firmware in his drone (with no updates, 3 days old bought from BestBuy) to my firmware update from the Autel website. I noticed that everything was the same except for the Sonar, his read V.0.0.9.5 and mine read V.0.0.0.0, so I called Autel and explained to them that I noticed a difference in firmware from my son's to mine. The rep told me to download the firmware again and keep reinstalling it till the sonar takes. I downloaded it 5 times and attempted to install it, but I noticed each time it started to unpack and install sonar firmware that it read V.0.0.9.4 not even the same firmware that the drone comes stock with. So I called back to Autel and got Dan which was one of the first rep's that I spoke with when all of this crap began and he asks me were I got the firmware from and I stated the Autel webite, he responds with that is and old firmware update and he is going to send me an e-mail with the new firmware (3.1.1), well hell that's a big difference from the 1.1.3 to 3.1.1, but even after downloading the new firmware the sonar still read v.0.0.9.4 as I watched it unpack and now in my Sonar firmware there is nothing, blank, so I call Autel the next day and get Jason on the phone explain that I attempted to install the new 3.1.1 firmware and now I don't have any Sonar firmware in my drone, he responds with you don't need sonar firmware, that the sonar don't even work right now and that it is safe to fly the drone without any Sonar, and that they are currently rewriting the firmware and that it is due to release sometime in the next 3 months or so, and once that new firmware is installed it will be like flying a new drone (our drones are less then 2 weeks old form the store). Does anyone have any input about the Sonar and what they do, because my last thought was that the sonar helps the drone determine it's altitude during the landing phase. Any help or input would gladly beappreciated.
     
  2. Your description of what the sonar is for is what I believe it is for. And IS needed for auto landing. I know for a fact that my sonar works after flying the drone off of a cliff. I went from 100' in elevation to 500'.

    Here is the 1.2.8 bin that was released back in August or somewhere close to that. You can try loading it onto your drone.

    http://www.mediafire.com/file/8l3it8o88e1s3dg/X3P_FW_900M_V1.2.8.zip

    Not sure what it will hurt to try it. If it fails, just return the drone for another one.
     
  3. V3 firmware ???!!!o_O
     
  4. You realize this thread was made on Jan 16, 2017?
     

Share This Page