Reliability and product support

Discussion in 'General' started by George Benedek, Oct 27, 2016.

  1. I own a Phantom 2 Vision + since June 2015. After about 15 flights, the WIFI module on board the aircraft failed. As a result, there is no video transmitted from the aircraft. Essentially rendering the drone useless.

    I contacted DJI support, long story short, cost me $154 to get the drone fixed. But hold on! It wasnt fixed. The drone was returned to me with no FPV. Had to send the drone back, it will take another 3 weeks (or perhaps even longer) to have the drone back in my hands.

    Needless to day, I am thoroughly unimpressed with DJI's product reliability and product support.

    I am thinking of switching to Autel. How reliable are their drones? What is it like dealing with their support personnel???

    Any info will be greatly appreciated.

    Thanks!!
     
  2. I've never had a DJI but quite a few people who have both prefer the X-Star. It does have some shortcomings. There is no third party software available for the X-Star, though I expect that it will be available in the future. There are quite a few comparisons on YouTube. Check out the reviews on Amazon. There is absolutely no doubt that Autel customer support is head and shoulders above DJI. I had a problem once on a Staurday afternoon. I called and was talking to a person in less than 30 seconds.

    I think an X-Star will probably be a step up from a Phantom 2, or a Phantom 3, for that matter. I think a Phantom 4 may be worth $200 more than an X-Star. If I was in the market, I might wait to see if the Mavic met expectations, but the X-Star is a good choice. I should mention that the X-Star shell is stronger than the Phantom's. Apparently the Phantoms crack on occasion.
     
  3. Tom,
    Thanks for the feedback.
     
  4. Just today I read one of the idiotic reviews I have seen. The reviewer said the X-Star was a $900 paperweight. Even if someone thinks there are better options than the X-Star, it is long, long way from a paperweight. While I was commenting on that review I saw a 10/30 review that included this, "Anyway I took my p3p back and exchanged it for this XStar Premium and I'm absolutely loving it !".

    I think I will create a new thread, but while I was looking up that idiotic review, I noticed that the X-Star WiFi is listed on Amazon for $499. That is a very good deal!
     
  5. I think their customer support is spot on.
     
  6. Autel is quick to respond to your calls, but I've noticed that there seems to be a diconnect from the individuals that answer the phones and the individuals (techs) that actual know what's going on. I recently purchased 2 new batteries and was told that I needed to download the firmware from the Autel website and install it for the new batteries to become matched to the aircraft. I was also told to run the firmware on the original battery that came with the X star premium. So upon completion of updating all three batteries my problems began. First think I saw was on battery #2 I received a warning on my monitor (unknown battery) while flying, I immediately landed the drone, powered everything down and turned everything back on. I didn't see that warning again for a couple of flights, but upon seeing I contacted Autel and they advised that I run the firmware on that battery again. Then the other day I was out flying and the drone had about 33% battery life left, and I knew it would be going into RTH soon so I let the aircraft go into a hover apprx. 650 feet away from me at approx 35 feet high. At 25% the drone did as it was suppose to and went into RTH mode. The aircraft went to 99 feet as preset and I thought it was on its way home, but it remained at 99 feet and wouldn't move (I mean nothing) I had zero control of the drone, it just sat there at 99 feet in a hover, then less then a minute later I got a critical low battery warning, I expected the drone to go into landing immediately phase, but yet again nothing. I tried everything that I could think of to get the drone to come down, the only thing that I noticed that worked was pressing the pause button the drone began a decent, so I let go of the pause button, but the drone began to climb and went back to 99 feet. So I again pressed and held the pause button and the drone began to come down (with 1 minute of flight time remaining I continued to hold the pause button as the drone was coming down and I didn't want it to return to 99 feet run out of battery life and fall to the ground. Pause was bringing it down, so I continued to hold it as it got about 5-6 feel from the ground my son (which had been out flying with me) reached out and grabbed the landing gear, I released the pause button and the motors reved back up as if it were attempting to climb, he pressed the power button on the battery and powered down the drone. I called Autel and explained to them what had just happened and the requested screen shots of all my batteries and the requested the bin files from the drone. They also request screen shoots of my firmware. I sent in all the info they requested and I waited for a response, 2 days later I called in to Autel to see if the had any info for me. They asked when I had last updated the firmware, and I told them 2 days ago. They said they could not see anything wrong with the drone or the batteries (but I did) after Autel requested all that info I powered up my son's drone (x star premium) and verified the firmware in his drone (with no updates, 3 days old bought from BestBuy) to my firmware update from the Autel website. I noticed that everything was the same except for the Sonar, his read V.0.0.9.5 and mine read V.0.0.0.0, so I called Autel and explained to them that I noticed a difference in firmware from my son's to mine. The rep told me to download the firmware again and keep reinstalling it till the sonar takes. I downloaded it 5 times and attempted to install it, but I noticed each time it started to unpack and install sonar firmware that it read V.0.0.9.4 not even the same firmware that the drone comes stock with. So I called back to Autel and got Dan which was one of the first rep's that I spoke with when all of this crap began and he asks me were I got the firmware from and I stated the Autel webite, he responds with that is and old firmware update and he is going to send me an e-mail with the new firmware (3.1.1), well hell that's a big difference from the 1.1.3 to 3.1.1, but even after downloading the new firmware the sonar still read v.0.0.9.4 as I watched it unpack and now in my Sonar firmware there is nothing, blank, so I call Autel the next day and get Jason on the phone explain that I attempted to install the new 3.1.1 firmware and now I don't have any Sonar firmware in my drone, he responds with you don't need sonar firmware, that the sonar don't even work right now and that it is safe to fly the drone without any Sonar, and that they are currently rewriting the firmware and that it is due to release sometime in the next 3 months or so, and once that new firmware is installed it will be like flying a new drone (our drones are less then 2 weeks old form the store). Does anyone have any input about the Sonar and what they do, because my last thought was that the sonar helps the drone determine it's altitude during the landing phase. Any help or input would gladly be appreciated.
     
  7. Well I am happy to say that my Drone is back up to 100%. Dan a rep at Autel was finally able to get me the Firmware file V.0.0.9.5 for the Sonar and the Drone accepted it. This would have been the last ditch effort before I would have had to send it back to Autel for them to figure out why it wasn't accepting the Sonar Firmware. This is why I picked Autel, relentless customer support. I heard of so many Horror stories about other drones and little to none customer support. Dan at customer support for Autel was always quick to respond to my e-mails and calls and I just want to say Thank You to him. Autel is still not sure why the Drone froze up the way it did and then not respond to the commands from them remote, but he did state that if something drastic would have happened that Autel would have had my back. That's the one thing that is nice is that this Drone records it's flights (sorta love a black box on an aircraft would) and they would be able to see what your drone was doing prior to a crash. Thankfully mine did not and is back in the air. On a side note I was told by Dan not to download Firmware into a new out of the box battery, just charge it and fly (plug and play) nice to know sense we are purchasing 3 more batteries for my son's and my drone, but also to keep the batteries separate from one Drone to the next.
     
  8. Glad you got it all sorted out. The statement that Dan told you should be posted on their website in big letters and to explain why. All the tutorials say different. noidea.gif
     
  9. So just to clarify the way I was told to install Firmware on my Drone by Dan at Autel was to erase any files on the SD card (format SD card, insure you have removed any vidoes or pics that you want) then download the Firmware to your computer (look for it in download file). Then transfer the file from your download file to your SD card, safely eject the SD card from your computer. Power up the Transmitter (remote control) and then the Drone, wait for the Drone to connect to the Transmitter, (I like having my Tablet up and running with the Transmitter as you can see easier when the Drone and Transmitter connect). Then put the SD card into the Drone, watch the screen on the Transmitter and you will see it display unpacking Firmware (it is automatic and there is nothing that you have to do) upon completion of the Firmware unpacking and installing it will display what it successfully installed and there will be a checkmark, if it failed there will be an X and you will have to repeat the entire process over again. These instructions are different from those in the tutorial online and on the Autel website.
     
  10. Seems to be the same as this video tutorial

     
  11. No they have you install the micro SD card into the Drone first then power up the Drone and the Transmitter, vs powering up the Drone and Transmitter first then inserting the SD Card into the Drone after they have established a connection. Watch the video again you'll see SD card inserted before powering everything up, vs what I was told to insert SD card after powering everything up then once they are connected insert the SD card. Clearly two different sets of instructions, the tutorial did not work on mine, but the way I was instructed by Dan worked.
     
  12. OK good to know.
     

Share This Page