Version 2.0

Discussion in 'News' started by bjtap, Jul 25, 2017.

  1. They have announced the release of the updated firmware release to 2.0. I even watched the two videos that show how to do it... but when I (and apparently some others) go to the download page it still shows v1.13. Here is the link on youtube to the 2.0 update:
    made by Autel.
    Exciting news and can't wait for complete resolution of all this!
     
  2. Apparently it is still a beta release... not final release. But the update videos are still out there.
     
  3. My guess is that when they release the final version, it will be V2.0
     
  4. Either way, I feel this is exciting news that shows Autel is 'out there'. I am a chicken and most likely will not participate in this beta version (which I guess is near completion) but I so look forward to it's final release. I will keep my eyes and ears pealed. My further guess is they would not have released the two 'update' videos unless it was pretty darn close to a final release.
     
    3 people like this.
  5. As of this morning, beta version is available directly from the front page of the Autel website, once you fill out the release form.
     
  6. Yes, it has moved to Open Beta, so anyone can download the latest version and update their X-star.
     
  7. Beta cured my magnetic interference and compass error issues.
     
  8. When I try to download it says it's loading V1.3.30. Is that what you guys saw?
     
  9. When I get it downloaded onto my computer the bin file name also says V1.3.30........
     
    2 people like this.
  10. yes, it throws everyone off. But that's it
     
    2 people like this.
  11. Yes it’s called V1.3.30 as the beta. My thinking is that once they release it officially, they’ll call it V2.0.
     
    2 people like this.
  12. Thank you guys very much for the clarification!!!! Appreciate your help!!!
     
  13. They've updated the update already. It's now labeled 2.0. I downloaded it this morning but haven't tried it to check changes. Here's a link to the latest version.

    https://www.autelrobotics.com/firmware-beta-download/

    P.S. Forgot to mention. It stated my RC was current and no update needed. Updated two files on the aircraft. Flight Control went from V2.0.25.0 to V2.0.27.0. Optical Flow updated but loaded the same version I already had, V0.6.8.0.
     
  14. I flew for about 20 minutes this afternoon. I really like it. I left the Yaw at the .20 setting. The Drone is so much faster at all actions now. I'll fly in open terrain for a couple hours to get used to it before going into the "jungle". :)

    The launch height is much less. The response after launch is quicker. I had hesitation to go upward before. The shutdown is much faster. The stability is much better. Changing direction is much faster. I'm still not sure it ascends faster. But it certainly does everything else faster.

    Only negative I noticed was it took a moment to connect with satellites. When finally connected it only had 11. Usually flying in this location I have 18-ish. I'll fly there a couple more times before I blame that on the update. Although I heard someone else say it connects slower. We'll see.

    Overall I really like the update. No glitches for me.
     
    2 people like this.
  15. cannot enable atti mode everything else is fine
     
  16. I get some serious back and forth yaw when trying to climb and go forward at the same time. Auto landing is a ton better.
     
  17. Still having problems with atti mode lights stays blinking green do not change to yellow, any suggestions,even tried using different tablet with new app installed,same thing, i can enable ioc mode on rc but nothing happens switching to atti mode.
     
  18. Is there a way to maybe revert to the old firmware , its frustrating.
     
  19. I've heard from a couple people saying you can't go back....
     
  20. pitty i will contact autel robotics and see what they can do.
     

Share This Page